Skip to main content


Topic: Problems with Color Object (Sphere v1.7alpha) (Read 3208 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
Problems with Color Object (Sphere v1.7alpha)
Hi everyone! It's good to know the community is still active after all this time. I just downloaded the version 1.7(alpha) from the repository. I'm not sure if there have been some changes with the API but I am having trouble accessing/assigning values to color objects - I somehow can't access correctly the individual properties (red,green,blue,alpha). I have been using v1.6 before so I don't know if this is a known issue with v1.7alpha.

  • DaVince
  • [*][*][*][*][*]
  • Administrator
  • Used Sphere for, like, half my life
Re: Problems with Color Object (Sphere v1.7alpha)
Reply #1
I remember 1.7 having some issues, one of them related to colour, but I don't remember exactly what it was. Probably better to stick with 1.6 or 1.5.

  • Fat Cerberus
  • [*][*][*][*][*]
  • Global Moderator
  • Sphere Developer
Re: Problems with Color Object (Sphere v1.7alpha)
Reply #2
Yeah, the Color object is broken in 1.7. I speak from experience there, having tried to use 1.7 myself and saw all my tweened colors get screwed up.  Nothing to be done for it other than going back to 1.6.  Just be aware if you do that you'll lose some JS functionality.
Sphere 5.6.2 - neoSphere engine - Cell compiler - SSj debugger
forum thread | on GitHub

Re: Problems with Color Object (Sphere v1.7alpha)
Reply #3
Yeah, I don't know why but colors in 1.7 are very... odd. (Especially in my private version which doesn't load images quite correctly, because I was trying to replace Corona and Sphere has some quirky parts that rely on it pretty heavily.)
If I ever do go back to developing Sphere 1.7 I'll be sure to fix the color thing.

Re: Problems with Color Object (Sphere v1.7alpha)
Reply #4
I also found that in 1.7, when I tried to run the Majestic it always reported that every surface contained at least one pixel of r0g0b0 and r255g255b255 respectively, no matter what. I never quite tracked down what was causing that.

Yeah, no joke about Corona quirks. Don't expect all images (TGAs, to be sure) saved with the old editor to work with anything but Corona/Sphere <= 1.6. That's a great example of why we should be moving away from Corona.

Re: Problems with Color Object (Sphere v1.7alpha)
Reply #5
Thanks for all the confirmation. It's just disappointing because I noticed that image drawing is faster in 1.7 :-\. Anyway, just going to stick with 1.6  ;)