Skip to main content

News

Topic: No more vsync (Read 2298 times) previous topic - next topic

  • Radnen
  • [*][*][*][*][*]
  • Senior Staff
  • Wise Warrior
No more vsync
Have you guys ever ran into the problem where Sphere can no longer vsync? I have the option turned on but I still see screen-tears. Furthermore, under vsync the fps usually drops to 60, but on my computer it's just not doing that. I don't know why it's not working. Any ideas?
If you use code to help you code you can use less code to code. Also, I have approximate knowledge of many things.

Sphere-sfml here
Sphere Studio editor here

  • N E O
  • [*][*][*][*][*]
  • Administrator
  • Senior Administrator
Re: No more vsync
Reply #1
Which version on what OS using what video driver?

  • Radnen
  • [*][*][*][*][*]
  • Senior Staff
  • Wise Warrior
Re: No more vsync
Reply #2
Windows 7 sp 1 with latest Nvidia drivers (I have a gtx 560ti). But I don't think it's a graphics hardware issue, right? I'm not running Sphere in GL mode, but who knows maybe Nvidia has something to do with screen refresh. I'll try to dig around on the internet for anything relating to this.

Edit: it appears from multiple posts on Nvidia forums that the latest rivers may in fact cause vsync issues.
  • Last Edit: March 13, 2014, 07:14:26 pm by Radnen
If you use code to help you code you can use less code to code. Also, I have approximate knowledge of many things.

Sphere-sfml here
Sphere Studio editor here

Re: No more vsync
Reply #3
VSync is (definitely in OpenGL, I would assume in DX and DD) completely up to your video card driver. I know that with OpenGL, you can only set the attribute and hope for the best. In addition, you can ovberride the setting of vsync from applications in the driver's configuration utility.

Does SphereGL have these issues in fullscreen? Sphere GL in fullscreen, for reasons unknown to me, is the only time it will run in doublebuffered mode.

  • Radnen
  • [*][*][*][*][*]
  • Senior Staff
  • Wise Warrior
Re: No more vsync
Reply #4

VSync is (definitely in OpenGL, I would assume in DX and DD) completely up to your video card driver. I know that with OpenGL, you can only set the attribute and hope for the best. In addition, you can ovberride the setting of vsync from applications in the driver's configuration utility.

Does SphereGL have these issues in fullscreen? Sphere GL in fullscreen, for reasons unknown to me, is the only time it will run in doublebuffered mode.


Usually vsync only works in full screen. But in my case going to full screen seems to not have any affect. The vsync check-box is checked in the options, so it should work but doesn't.

I could do a more accurate test in SSFML and see if it's vsync is working or not. The nvidia issue doesn't seem to be consistent. It only affects some things, apparently Vanilla Sphere being one of them.
If you use code to help you code you can use less code to code. Also, I have approximate knowledge of many things.

Sphere-sfml here
Sphere Studio editor here

Re: No more vsync
Reply #5
It probably also matters how exactly an application asks for vsync.

  • Radnen
  • [*][*][*][*][*]
  • Senior Staff
  • Wise Warrior
Re: No more vsync
Reply #6

It probably also matters how exactly an application asks for vsync.


You are right, there was an override and it was set to always turn off vsync. But that's strange since I never touched any overrides - ever. Just a few days ago I tried vsync and it worked normally. Nvidia keeps changing these little things and changing your overrides each time I update the driver. I did update the driver in the last couple of days and I suspect that is the culprit.

So, for future reference if anyone else is having this issue: check your driver settings and make sure vsync wasn't automatically disabled for all or some of your apps.
If you use code to help you code you can use less code to code. Also, I have approximate knowledge of many things.

Sphere-sfml here
Sphere Studio editor here

Re: No more vsync
Reply #7
Or you could use FJ-GL. Because of how it's built, so long as you have OpenGL 3.x or greater, it will never have tearing =P

Re: No more vsync
Reply #8
I had the same issue. I only found it because of your post (Nvidea Geforce 650 TI)