Skip to main content

News

Topic: [Solved] No option to use minisphere in editor (Read 126 times) previous topic - next topic

[Solved] No option to use minisphere in editor
So I may or may not be getting into Sphere again, so I uninstalled the minisphere I had (along with Sphere Studio) and installed minisphere 5.0. However when opening Sphere Studio (fresh installed from the ms5.0 exe), I only get the option to use the Sphere 1.5 engine.

Going into settings gave no option for locating the mini sphere directory or plugins. Anybody know what's up with this? Am I just missing something really simple?
  • Last Edit: October 26, 2017, 02:43:59 am by Datomas

  • Fat Cerberus
  • [*][*][*][*][*]
  • Global Moderator
  • miniSphere Developer
Re: No option to use minisphere in editor
Reply #1
Hm, I just did a fresh install of miniSphere 5.0rc and ran the bundled Sphere Studio, and got the option to use miniSphere.

Try opening Tools -> Configuration Manager and make sure "miniSphere Support" is checked.  If it's not listed, you could try reinstalling miniSphere again and make sure all the components are checked in the setup.
miniSphere 5.0.1 - Cell compiler - SSj debugger - thread | on GitHub
For the sake of our continued health I very much hope that Fat Cerberus does not become skilled enough at whatever arcane art it would require to cause computers to spawn enourmous man eating pigs ~Rhuan

Re: No option to use minisphere in editor
Reply #2
I'll have to wait until I get home as I'm working now but I did have everything checked except for building a project in Cell I think.

  • Fat Cerberus
  • [*][*][*][*][*]
  • Global Moderator
  • miniSphere Developer
Re: No option to use minisphere in editor
Reply #3
If you didn't install the GDK tools that's probably why it's not working.  The miniSphere support plugin for Sphere Studio relies on Cell to build your game.
miniSphere 5.0.1 - Cell compiler - SSj debugger - thread | on GitHub
For the sake of our continued health I very much hope that Fat Cerberus does not become skilled enough at whatever arcane art it would require to cause computers to spawn enourmous man eating pigs ~Rhuan

Re: No option to use minisphere in editor
Reply #4
It was the option to use the GDK in the command line, not Cell that I wasn't installing. Still, just reinstalled, checking even that, and still, nothing.


  • Fat Cerberus
  • [*][*][*][*][*]
  • Global Moderator
  • miniSphere Developer
Re: No option to use minisphere in editor
Reply #5
If you mean this option in the installer:
Quote
Sphere GDK command-line tools (Cell, SSj)

The Sphere Studio plugin also depends on those for full functionality. ;)  I should probably reword that to "development tools" or something, to make it less confusing.

But anyway this is weird since I know it works for me if I do a clean install.  The only thing I can think of that might be going wrong is if it's picking up an old version of miniSphereGdkPlugin.dll somewhere that wasn't deleted for some reason...
miniSphere 5.0.1 - Cell compiler - SSj debugger - thread | on GitHub
For the sake of our continued health I very much hope that Fat Cerberus does not become skilled enough at whatever arcane art it would require to cause computers to spawn enourmous man eating pigs ~Rhuan

  • Fat Cerberus
  • [*][*][*][*][*]
  • Global Moderator
  • miniSphere Developer
Re: No option to use minisphere in editor
Reply #6
@Datomas Just to be sure, Sphere Studio looks for plugins in the following folders (in this order):

  • My Documents -> Sphere Studio\Plugins
  • C:\ProgramData\Sphere Studio\Plugins
  • Sphere Studio installation directory -> Plugins

Make sure all except #3 don't have a miniSphereGdkPlugin.dll and delete it if they do.
miniSphere 5.0.1 - Cell compiler - SSj debugger - thread | on GitHub
For the sake of our continued health I very much hope that Fat Cerberus does not become skilled enough at whatever arcane art it would require to cause computers to spawn enourmous man eating pigs ~Rhuan

Re: No option to use minisphere in editor
Reply #7
Yup - the plugin was in the ProgramData directory, deleting that fixed it.

Thanks!

  • Fat Cerberus
  • [*][*][*][*][*]
  • Global Moderator
  • miniSphere Developer
Re: No option to use minisphere in editor
Reply #8
No problem, glad to hear it's fixed. :D

Just in case anyone else hits this I'll add an error message if a plugin fails to load to make it more obvious that something went wrong.
miniSphere 5.0.1 - Cell compiler - SSj debugger - thread | on GitHub
For the sake of our continued health I very much hope that Fat Cerberus does not become skilled enough at whatever arcane art it would require to cause computers to spawn enourmous man eating pigs ~Rhuan