Skip to main content

News

Recent Posts

1
Spherical News / Re: Announcement: wiki updates
Last post by DaVince -
The wiki is back!

This took a lot of pain and agony to get working, but finally, things are back to normal! I'm sure that things may not function entirely right everywhere, but at the very least the wiki is accessible, existing accounts work and pages and categories all seem to display correctly.

Account creation is disabled to prevent spam for the time being. I may set up a ReCAPTCHA account creation system, but for the time being, if you don't have an account, you can request one from me.
2
If it comes down to that, maybe you should just do a complete wipe of the wiki, configuration, pages, and all.
That's exactly what I meant! It's happening right now, after doing a backup of the database of course.
3
Engine Development / Re: miniSphere 4.8.4
Last post by Eggbert -
I'm starting to seriously work on porting miniSphere to Android. After a lot of frustration, I'm finally starting to get Allegro to work. I already got duktape to work a while ago, since that was obviously pretty easy.

https://joelme.twilightparadox.com/s/tlh9TFLdNPHvwZ6
4
Script Support / Re: GetVersion Question
Last post by Miscreant -
The vid card is actually in the 8500 series but even that is like 10 years old...

There must be some way to accomplish this.

Too much to think about right now...

For now, back to Sphere 1.5...
5
Script Support / Re: GetVersion Question
Last post by Fat Cerberus -
Without having access to a machine that old I can only guess at what's wrong, unfortunately. :(

The only thing that comes to mind is the change to backbuffer handling I did in mS 4.6: the engine now uses a fake backbuffer to ensure pixel-perfect output, and your 7300 may not be able to do render-to-texture at all.  In that case Allegro is probably emulating it in software, hence the slowdown.  If that's indeed the case, then there's not much I can do--using Surfaces in miniSphere would be slow for you too, even under 4.5.
6
Script Support / Re: GetVersion Question
Last post by Miscreant -
I'm not sure what all the specs are by memory. I can say that the machine I used before this one was almost 20 years old though.

although. miniSphere 4.5.xx functioned with no slow down of graphics.
7
Script Support / Re: GetVersion Question
Last post by Fat Cerberus -
Wow, GeForce 7300 is circa 2005... so that's a pretty old machine then.  The oldest PC I think I have access to is an Athlon X4 635 from around 2010.  I can look into it to try to figure out what caused the performance regression but I don't think you're ever going to get miniSphere to run adequately on that machine.
8
Script Support / Re: GetVersion Question
Last post by Miscreant -
I'm pretty sure my vid card is a nVidia GeForce 7300.
9
Script Support / Re: GetVersion Question
Last post by Fat Cerberus -
CPU-wise, requirements should be on par with Sphere 1.5 (in fact Duktape is 2-3x faster than the old SpiderMonkey used by 1.5).  GPU requirement is definitely a lot higher though, since it's all shader-based nowadays (1.5 is software-rendered unless you use the horribly optimized OpenGL plugin).

In the absence of a dedicated graphics card, I'm going to say the minimum requirement would be a Sandy Bridge i5, circa 2011.
10
Script Support / Re: GetVersion Question
Last post by Miscreant -
I'm developing on a quad core with 4gigs of memory.

Are there min reqs for miniSphere?